error execution phase preflight: [preflight] Some fatal errors occurred: [ERROR Swap]: running with swap on is not supported. Please disable swap


# kubeadm init                    
I0327 22:01:14.801409  647102 version.go:252] remote version is much newer: v1.20.5; falling back to: stable-1.18
W0327 22:01:15.235771  647102 configset.go:202] WARNING: kubeadm cannot validate component configs for API groups [kubelet.config.k8s.io kubeproxy.config.k8s.io]
[init] Using Kubernetes version: v1.18.17
[preflight] Running pre-flight checks
 [WARNING Service-Docker]: docker service is not enabled, please run 'systemctl enable docker.service'
error execution phase preflight: [preflight] Some fatal errors occurred:
 [ERROR Swap]: running with swap on is not supported. Please disable swap
[preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...`
To see the stack trace of this error execute with --v=5 or higher
Ответы
kubeadm init --ignore-preflight-errors Swap

Возможно будут интересны и другие вопросы
© RemiZOffAlex